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OVERVIEW

The  ON1 Professional Plugin Series provides seamless in-
tegration between your favorite ON1® editing tools and 
Adobe Photoshop® and Lightroom Classic®.  In this book, 
we’ll cover everything you need to know about using ON1 

Plugins to expand your Adobe workflow. 

	 First, let’s discuss what each of the plugins in the ON1 
Professional Series does and how they can help your pho-

to editing. 
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ON1 EFFECTS

ON1 Effects is your one-stop shop for professional looks and creative edits. ON1 Effects 
houses hundreds of filters and presets that you can stack, blend, and mask onto your pho-
tos. The filters inside of Effects include LUTs, a Channel Mixer, Sun Flares, Weather, Lens 
Blur, and more. ON1 Effects also comes equipped with spot retouching tools, refine tools, 
and local adjustments. As a plugin with Adobe, it’s most commonly used to style photo-

graphs and build looks. 

If you’re using Adobe Photoshop or Lightroom as your primary editor, ON1 Effects can 
make styling and adjusting the looks of your images a lot easier. In Effects, each filter 

comes with its own set of modifier sliders, presets, masks, and blending options, making 
it a fast and more powerful alternative to Photoshop’s adjustment layers. With Lightroom, 
it’s an excellent companion for editing workflows that yearn for more creative control and 
styling options. All of the filters and even the presets can be selectively applied using the 
masking brushes, gradients, and shapes built-in to ON1 Effects. Smart Filters (through 

Smart Objects) and Smart Photos (through Lightroom) can be used to keep track of all the 
adjustments made in ON1 Effects, allowing individual layers or photos to be readjusted 

and modified instantly. 
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ON1 PORTRAIT AI

ON1 Portrait AI provides portrait photographers with flawless skin retouching through AI 
face-detection technology. Portrait AI automatically detects all of the faces in portraits and 
automatically applies the right amount of skin retouching. Portraits with multiple people in 

them will have individual retouching filters applied to each face. The masks and skin re-
touching can be modified entirely and customized based on your preferences. 

ON1 Portrait AI makes skin retouching effortless. Manual retouching in Photoshop is done 
through multiple layers and blend modes using different blurs. In ON1 Portrait AI, each 
face is found, analyzed, and retouched automatically. Portrait AI takes the hassle out of 

portrait retouching through responsive sliders and easy-to-use modifiers. As a companion 
to Photoshop and Lightroom, groups of portraits can be batch processed and retouched 

in no time. 

Portrait AI is an invaluable tool for portrait photographers looking to drastically speed up 
their retouching workflow with batch processing and automatic face detection. 

 U S I N G  O N 1  P L U G I N S  T H R O U G H  A D O B E /  P A G E  6 



ON1 HDR

ON1 HDR houses everything a photographer would need to create stunning HDR images. 
As a dedicated HDR application, ON1 HDR can merge exposure brackets in far less time 
than Photoshop or Lightroom and with a wide selection of tools and options. ON1 HDR 

offers a develop, effects, and local adjustments tab, along with retouching, masking, and 
refining tools, offering much more flexibility when modifying tone and style. 
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ON1 RESIZE

Featuring ON1’s industry-leading Genuine Fractals® technology, ON1 Resize provides pho-
tographers with the ability to enlarge any photo up to any size. All while maintaining the 
original detail and quality. ON1 Resize comes equipped with print and enlargement pre-

sets as well as a dedicated print module for in-depth printing preparation. Quickly enlarge 
images, sharpen details, create gallery wraps, and tile in a powerful, easy-to-use plugin. 
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USING ON1 PLUGINS WITH 
ADOBE PHOTOSHOP & PHOTOSHOP 

ELEMENTS

ON1 plugins are accessible f rom with-
in Photoshop in two ways, f rom the File 
> Automate menu and the Filter > ON1 
menu. Automation plugins (using the 
Automate menu to select a plugin) allow 
you to batch process using Actions. Au-
tomation plugins can also do things like 
change layers and change the canvas 
size. Filters can only affect the pixels on 
the selected layer. If you want the results 
to be added to their own layer, go through 
the Automate menu. The Filter and Auto-
mate menu both have the option to send 
images to Effects and Portrait AI. You 
can also use the Filter menu to “Convert 
for Smart Filters”, which allows you to 
re-edit and readjust any of the changes 
made with ON1 plugins. (We’ll talk more 
in-depth about Smart Filters and batch 
processing later in the chapter.) Note: In 
Photoshop Elements, the automation 
menu is called “Automation Tools”.

You can also use the Filter menu to ini-
tiate your last-used f ilter. For example, 
suppose you sent an image to ON1 Ef-

fects, applied the Black and White Filter, 
and returned to Photoshop. In that case, 
you could quickly apply that same mod-
if ication to the next image you open in 
Photoshop with the Filter menu. 

By default, when you send an image to 
an ON1 plugin through the Automate or 
Filter menu, the plugin creates a copy of 
the current layer that’s selected. When 
using the Filter menu to apply your last-
used ON1 plugin adjustment, Photoshop 
will not make a copy of the current lay-
er. In each of the ON1 plugins compati-
ble with Photoshop, you can modify your 
default f ile types and how the results are 
applied through the Preferences. 

Note: ON1 Plugins only support 8 and 16-
bit RGB images. If the menu items are 
disabled, the current layer or photo type 
isn’t supported, such as a text layer or 
adjustment layer.
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SELECTIONS, MASKS, 
AND LAYERED PHOTOS

P H O T O S H O P

The ON1 plugins will work with any 
pixeled layer of your image in Pho-
toshop, f rom selections to masks. 
Remember that ON1 plugins will only 
modify the layer or a chosen section 
of a pixeled layer. They do not support 
text or adjustment layers. When you 
don’t have a selection, ON1 plugins 
will apply to the entire layer. This is 
the most common way to use them.
 

Selections

When you select an area on your im-
age with a selection tool in Photo-
shop, you can modify that selection 
through ON1 Effects and Portrait 
AI. For example, if the Lasso Tool is 

selected and you outline a single 
tree in your landscape image, you 
can use the Automate or File menu 
to send that piece of your image to 
ON1 Effects or Portrait AI for modif i-
cation. To do this, use any selection 
tool inside of Photoshop to select an 
area on your layer. Now use the File 
> Automate menu or the Filter > ON1 
menu to send to the desired selection 
ON1 Effects or Portrait AI. Once you’ve 
modif ied the selection inside of the 
ON1 plugin, select Done at the bottom 
right corner to complete the modif i-
cation and return to Photoshop. You 
can also apply the last-used f ilter by 
right-clicking on the selection. 
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Masks & Layers

When working with multiple layers and 
masks in Photoshop, you can send the 
desired layer, along with their mask, 
over to ON1 Effects or Portrait AI. Be-
cause the mask comes along with the 
layer to Effects or Portrait AI, you can 
readjust the mask once you return to 
Photoshop. When sending layers and 
layers with masks over to Effects or Por-
trait AI, remember to have the desired 
layer chosen that you want to modify. 
You can use the same “File > Automate 

menu or the Filter > ON1 menu” method 
to access the ON1 plugins. 

If you enjoy using the masking tools in-
side of ON1 plugins, such as the AI Quick 
Mask Tool or the Perfect Brush, you can 
you can create and modify layer masks 
in ON1 and have the layer mask return 
to Photoshop.
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Re-editability with Smart Filters

	 Smart Filters give you the ability to 
readjust the modif ications you’ve cre-
ated through an ON1 plugin. To create 
a Smart Filter, you need to convert your 
layer to a Smart Object. To convert your 
image to a Smart Object, right-click 
the layer and select “Convert to Smart 
Object” or use Filter > Convert for Smart 
Filters. Once your layer is converted to 
a Smart Object, all of the modif ications 
done through ON1 plugins will be saved 

so that you can remodify and readjust 
them once you’re back in Photoshop. 

To readjust the changes you’ve made in 
an ON1 plugin, right-click on the Smart 
Filter and select “Edit Smart Filter” or 
double-click on the Smart Filter icon. A 
Smart Filter will also create a mask for 
the layer in Photoshop, allowing you to 
paint away or blend the look. 
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Batch Processing with Actions

In Photoshop, Actions allow you to save a series of steps in an editing workflow. Through Photoshop 
Actions, ON1 plugins can batch process groups of images. Actions also will enable you to capture your 
ON1 plugin workflow so that you can quickly apply those steps to any image you work on in the future. 

To create an Action:

1.	 Go into your Window menu and make sure 

that the Actions pane is enabled.

2.	 In the Actions pane, use the plus icon at the 

bottom right to create a new action.

3.	 Name your Action and then choose Record to 

begin recording your steps. 

4.	 Use File > Automate menu or the Filter > ON1 

menu to send your layer to an ON1 plugin. 

5.	 When you’re done modifying your layer in the 

ON1 plugin and have returned to Photoshop, 

stop the recording. The Stop recording button 

is near the bottom left next to the Record but-

ton. 

You’ve saved your ON1 plugin workflow as an Ac-

tion! To run the Action on an image, select the Play 

icon. 

Now, let’s use Automate to batch process a group 

of images. 
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U S I N G  O N 1  P L U G I N S  T H R O U G H  A D O B E

Batch Processing with Actions (Cont.)

	 To batch process groups of images, 
use the File > Automate menu to navi-
gate to “Batch...” option. 
•	 The Play section near the top left in 

the Batch dialogue is where you’ll 
choose the Action that you created. 

•	 Use the “Choose” option in the Source 
section below to select the Folder of 
photos you want to batch process. 

•	 Use the Destination section on the 

far right to choose a folder for the 
processed images. After you’ve mod-
if ied the naming options, select OK to 
batch process. 
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Accessing ON1 plugins inside Lightroom can be 
done in two ways, via the File > Plug-in Extras 
menu and the Photo > Edit In menu. 

If you’re looking to batch process or create Smart 
Photos for re-editability, use the Plug-in Extras 
menu. With the Plug-in Extras menu, you are us-
ing Lightroom’s plugin export system to control 
the characteristics of the edited file. Through the 
Plug-in Extras menu, you can convert images into 
a Smart Photo format. Smart Photos save all of 
the edits made in ON1 plugins so that you can re-
adjust them in the future (we’ll dive deeper into 
Smart Photos later in the chapter.)

The Plug-in Extras menu also houses the Merge 
with ON1 HDR Standalone option and Edit in ON1 
HDR Standalone option if you need to merge HDR 
exposure brackets. To merge exposure brackets 
together with ON1 HDR, select the series of 
exposure brackets and use the Plug-in Extras 

menu to select Merge with ON1 HDR Standalone. 
If you need to readjust HDR photos, use the Edit 
in ON1 HDR Standalone option. 

Note: ON1 standalone apps can also be used as ex-
ternal editors through the Edit-In menu in Lightroom, 
but it is recommended you use Plugin Extras for the 
best experience.

USING ON1 PLUGINS WITH
ADOBE LIGHTROOM CLASSIC
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L I G H T R O O M

Export Options

An Export Options dialogue opens be-
fore you access an ON1 plugin through 
Lightroom. The Export Options allow you 
to modify the f ile handling options for 
that image. Through the Edit In menu, 
the Export Options are Edit a Copy with 
Lightroom Settings, Edit a Copy, and Edit 
Original. If you have Lightroom settings 
applied that you want to keep in your ad-
justment, use the Edit a Copy with Light-
room Settings option. 

If you do not wish to keep the Lightroom 
settings applied, if any, use the Edit a 
Copy option. If you’re not modifying a 
RAW f ile, you can choose to Edit Original 
and adjust the original f ile. Use the Copy 
Options section below this area to select 
your desired f ile format.

You can also modify the f ile type, color 
space, bit depth, and size in the Export 
Options dialogue. When you access an 
ON1 Plug through Lightroom’s Plug-In 
Extras menu, the default f ile handling 
options are driven by the settings in the 
plugin’s Preferences File Handling tab. 
These options can be conf igured in ad-
vance, based on your workflow, and can 
be changed as desired.
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Export Options (Cont.)

Inside of the Plug-ins tab in your plugin’s 
Preferences, the f ile export options in-
clude the following settings:
•	 File Type: This determines what type 

of f ile will be created. The default is 
PSD, which does not support re-edit-
ability. You can also select Smart Pho-
to PSD, JPG or TIFF, if you prefer those 
formats. One other option, Same as 
Source, will edit the original f ile; if that 
f ile is in the Raw format, it will be sent 
as a PSD f ile. 

•	 Color Space: The color space menu 
determines which RGB working color 
space is used; Adobe RGB 1998, sRGB 
or ProPhoto RGB. 

•	 Bit Depth: Sets the exported f ile’s bit 
depth to either 8 or 16 bits per pixel. 

•	 Resolution: Determines the resolution 
of the newly created f ile. 

•	 Stack with Original: When enabled, 
the new image is stacked with the 
original image upon return to Light-
room f rom Effects. 

•	 Use Original for Single PSDs: When 
enabled, if you select a single image 
in PSD format, the original f ile will 
be edited, rather than having a copy 
made.
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L I G H T R O O M

Re-editability with Smart Photos

ON1’s Smart Photo technology is a varia-
tion of the Photoshop f ile format that has 
been engineered to preserve all editing 
and retouching operations made within 
an ON1 plugin: f ilter operations, masks, 
local adjustments, retouching, and so 
forth. Smart Photos can only be created 
via the Plug-in Extras menu, although 
you can re-edit them via either the Plug-
in Extras or the Edit In menu options 
in Lightroom. When you choose Smart 
Photo PSD as an option in the Plug-in 
Extras submenu f rom within Lightroom, 
the ON1 plugin creates a standard Photo-
shop f ile with “Smart Photo” at the end 
of the original f ile’s name. As you work in 
the ON1 plugin, all of your editing opera-
tions are saved within the f ile.

	 When you are done editing and re-
turn to Lightroom, your edited photo will 

look as it did in the plugin, but is com-
pletely re-editable. 

To re-edit a Smart Photo f rom within 
Lightroom, select the image, and choose 
the appropriate Edit module tab f rom 
either the Plug-in Extras f rom the File 
menu or Edit In f rom the Photo menu. 
Depending upon the method chosen 
and your plugin Preferences, the Smart 
Photo will open automatically, or you 
will need to select Edit Original f rom the 
Lightroom export window. 

If you open a Smart Photo in Adobe Pho-
toshop, the layers will be merged into a 
single, composite layer. If you make any 
edits to the photo and save it, re-edit-
ability in the ON1 plugins will no longer 
be available.
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L I G H T R O O M

Batch Processing

You can process multiple images through 
your desired ON1 plugin through the 
Plug-in Extras menu. Select the imag-
es you want to process and select your 
desired plugin through the File > Plug-
in Extras menu. In the Export Options, 
you’ll see a Batch Options section now. 

These options do the following:
•	 Pause on First Photo: Use this option 

when you wish to apply the exact 
same editing operations to a group of 
photos. This option will open the f irst 
selected image inside the ON1 plugin. 
There, you can perform any editing 
options you wish. When you have f in-
ished with your edits, click Done. The 
ON1 plugin will then apply all of the 
edits to the photographs in the select-
ed group. 

•	 Pause on All Photos: This option lets 
you sequentially edit the images in 
the batch. The ON1 plugin will open 
each image, where you can edit it as 
desired. When you are f inished edit-
ing with one photo, click Done, and 
the plugin will save that photo and 
open the next one, with the previous 

photo’s settings applied. (You can re-
set any or all of those settings as de-
sired.) When you have f inished editing 
the last photo in the group, clicking 
Done will save the image, close the 
ON1 plugin and return you to Light-
room.

•	 *When using Portrait AI: Use AI Auto 
for all Found Faces: This option will 
launch Portrait AI, automatically f ind 
all the faces in each photo and retouch 
each one according to the default set-
ting—Subtle or Strong— set in Portrait 
AI’s General Preferences. No other ed-
iting is done, and the batched photos 
are displayed inside Lightroom when 
the process is complete.
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